wordpressでiframeを使うための覚書。

wordpressでiframe使うのはタイヘン!
wordpressでiframeを使う・・・

 

そう、wordpressって標準で使うとエディタを切り替えただけで

「iframe」タグを消しちゃうんですよね~!

困るんですよね~、これって。

 

で、いろいろ調べて

WordPress のビジュアルエディターで iframe を使えるようにする を参考に

テーマのfunctions.phpに

 

 

 

を入れたらいいとあったので早速試したけどダメ!

どうやら、wordpressのバージョンが3.1以上だと効かないらしい、このおまじない。

 

で、3.1以上のバージョンをお使いの方はTSL iframe unfilterっていうプラグインをインストールしてみましょう。

WordPress3.1.xでビジュアルエディタでiframeを使えるようにする | 世界 – @daipresents ←こちらを見つけてラッキーでした♪ありがとう!

インストールして有効化するだけです!

ほんと、作者さまに感謝ですね~♪

 

 

 

 

2 comments Add yours
  1. こんにちは、はじめまして。

    上記『WordPress のビジュアルエディターで iframe を使えるようにする』の記事を書いた者です。
    この度は、リンクありがとうございます。

    さて、WordPress のバージョンが3.1以降だと動作しないという事ですが、当方のバージョンは英語版・日本語版とも3.1.3です。
    どちらも問題なく動作してるようですので、バージョンではなく別の原因があるのかも知れません。
    もし、原因がおわかりになりましたら、今後のためにご教示いただけますでしょうか。

    それでは失礼します。

    1. nipper さま。はじめまして。

      コメントありがとうございます!

      そうですか・・・
      ところが、わたしの場合、うまくいかなくて。

      ご指導のとおり、「半角・改行を削除してバージョン3.1以前のwordpressでは動作してます、感謝いたします♪

      なんでなんですかね~、、、

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA